IPFire 2.13 – Core Update 73 comes with a bunch of smaller bugfixes and updates. The most important ones of these are updates of the squid web proxy server, openssh and the PHP Hypertext Processor. It is recommend to update as soon as possible.

squid 3.3

The squid web proxy server has been updated to version 3.3.10. The most notable changes since the current version of squid running in IPFire are better SMP scalability, an updated logging infrastructure and fixes all over the place.

The transparent mode has been dropped in favour of the more general intercept mode, which requires a different port than for the transparent mode. There is no intervention by the user required, when updating your IPFire system, as the a new port for this service will automatically chosen and configured.

Also, the default number of file descriptors has been increased for new installations.

php 5.3.27

PHP has been updated to version 5.3.27, which fixes a whole bunch of bugs as usual. Modules for ZIP and sqlite2 are compiled in now.

Misc. changes

  • openssh has been updated to version 6.4p1.
  • Wireless Client: You can now use an apostrophe (’) in the SSID string (#10427). There has also been some help added for the priority option (#10428).
  • Static Routes: Fix validating IP addresses (e.g. 10.0.0.0 was recognized as a wrong IP address).
  • Formerly, when a network interface for the blue or orange network zone has been assigned, but blue or orange were not enabled, various CGI scripts crashed. This has been fixed now.


The release of this Core Update was delayed because the developers are currently working on the next major version of IPFire. To support us all, please consider sending us a donation or join the team to help busting bugs!

Michael Tremer - November 26, 2013 at 7:42 pm