Today, we are releasing the 63rd Core Update for IPFire 2.11. This update fixes some minor problems and fixes two security issues in apache.

Software updates

  • apache2 – 2.2.23 – because of CVE-2012-2687 aka CVE-2008-0455 and CVE-2012-0883
  • dhcp – 4.2.2 – because the older version got confused with VLANs
  • fireinfo – 2.1.6 – Ignore some more invalid ID strings

Other bug fixes

The long awaited OpenVPN fragment/mssfix bug has been fixed and the network-vlans initscript is not too noisy any more.
Despite that, some invalid HTML output was generated by the index.cgi script, which has been reported by mrkaehler. Thank you.

We recommend to update as soon as possible. If you like this update as much as we do, please donate.

Michael Tremer - October 19, 2012 at 8:00 am